Alfresco Community 5.0.a Release Notes

From alfrescowiki

Jump to: navigation, search

Alfresco 5.0.a Community Release

The following note provides information on Alfresco Community 5.0.a release, which is the first community release for Alfresco 5.0. This release will be followed by more 5.0 community releases in coming weeks. This is the first version of Alfresco Community built entirely with maven.

Alfresco Community 5.0.a release contains the bug fixes since the Community 4.2.e release. See the list of the issues fixed since 4.2.e.

Being the first community release for 5.0, this has undergone limited testing and care should taken before upgrading any previous Alfresco Community version with this version.

Note that JDK 1.7 is required for this release.

Installation

For download and installation instructions, refer to the Download and Install Alfresco page..

Prerequisites

  • DB: MySQL 5.6 or PostgreSQL 9.2.4
  • App Server: Tomcat 7.0.53
  • JDK Version: 1.7.0 u60

The Alfresco supplied Installers will install all you need to run Alfresco on your machine; which includes JDK, Tomcat, SOLR, Share, Google Docs integration, LibreOffice, Sharepoint module etc.

Note: JVM memory now defaults to max 2GB.

Note: latest patches are always recommended.

Schema Changes

Known Issues

Please refer to Alfresco JIRA system known issues in Community 5.0

Major Changes

Most of the feature changes in 5.0.a are documented in this blog post by Kevin Roast.

Public SVN revision number for Alfresco Community 5.0.a is 75118

Personal tools
© 2014 Alfresco Software, Inc. All Rights Reserved. Legal | Privacy | Accessibility